
Did you know that…
…Anarchie comes complete with online help?

The Help menu is the question mark in the top right-hand corner of your screen. Open 
Anarchie's online manual by selecting Anarchie Guide from the Help menu.

Anarchie also has complete documentation in SimpleText format, Balloon Help, and these 
Tips. All the documentation is available on the Web. (To find out how to get to our Web site 
click the Next Tip button below.)
Did you know that…
…Anarchie has its own Web page?

You can read the latest Anarchie news on the Anarchie Web page at:

      <http://www.stairways.com/stairways/anarchie/>

(Command-click the above URL to open it.)
Did you know that…
…you can find out how to pronounce Anarchie?

Open Anarchie's online help by selecting Anarchie Guide from the Help menu, click Topics, 
click Introduction, and then double click How do I pronounce Anarchie?. The voice is that of 
Quinn "The Eskimo".

The Help menu is a question mark in the top right-hand corner of the menu bar.
Did you know that…
…you can correct a mistake in a failed FTP transfer?

Anarchie displays an Edit Retry button when a transfer fails. Clicking Edit Retry brings up a 
FTP… window with all the information about the failed download.

In fact, if you hold the Control key down when you double click a file in a listing window a 
FTP… window appears!
Did you know that…
…we have an incredibly cool bunch of beta testers?

Anarchie went out to a mailing list of over four hundred beta testers. Most of them checked 
Anarchie on their machines which helped reassure us that there weren't any major bugs or 
incompatibilities. Others exhaustively checked functions, grammar and spelling. What can 
we say? We're humbled.

Thank you beta testers for your vigilance!
Did you know that…
…you can quickly search a single FTP site?

Open a FTP… window from the FTP menu and click the Site Index radio button. Specify the 
FTP site you wish to search in the Machine field and what you wish to search for in the Index 
field, then click the Index button. Anarchie then asks the FTP server to search for your file.
Did you know that…
…you can set your default Archie server?

Open Internet Config by selecting Preferences in the Edit menu and clicking the Launch 
Internet Config button. Click File Transfer and select your preferred Archie site from the pop-



up menu. Anarchie then uses this site by default when doing Archie searches.
Words from the Oracle…

The trouble with doing something right the first time is that nobody appreciates how difficult 
it was.
Did you know that…
…you can go to the Stairways Web site from within Anarchie?

Open the About box (from the Apple menu) and click the Stairways logo.
Did you know that…
…you can find out how much data remains to be transferred?

During a download click the Total field and it cycles through:
            Total
            Transferred
            Remaining
Did you know that…
…you can get context sensitive help?

Balloon Help is context sensitive: the help message changes depending on where your 
cursor is pointing. Turn on Balloon Help by going to the Help menu and selecting Show 
Balloons. Turn off Balloon Help by going to the Help menu and selecting Hide Balloons.

The Help menu is a question mark in the top right-hand corner of your screen.
Did you know that…
…you can update the current listing with a simple menu command?

A file listing is a snapshot of the FTP site at some point in time. Update the file listing by 
selecting Retry from the File menu or using the Command key equivalent of Command-R.
Did you know that…
…you can edit your next download?

Hold the Control key down when you double click a file in a listing window, and Anarchie 
brings up FTP… window with the file's details.

The Control key is a modifier that means ‘Edit’ throughout Anarchie.
Did you know that…
…you can move up a directory?

Anarchie supports the same navigation keys as the Finder: in a listing window type 
Command-Up arrow to move up a directory, or Command-click the window's name in the 
title bar to view a pop-up menu of all the parent directories.
Did you know that…
…you can move up multiple directories with one click?

Command-click the window's name in the title bar of a listing window and you can chose 
which parent directory you would like to open from a pop-up menu.
Did you know that…
…you can just drag files or folders to the Finder to download them?

In fact, whether you are uploading or downloading files you can just drag the files or folders 
into or out of the listing windows (respectively).



Note: This requires System 7.5.    You can install the Drag Manager in System 7.1 upwards.
Words from the Oracle…

Anything that is good and useful is made of chocolate.
Did you know that…
…you can look at listings in order of size?

File listings in Anarchie behave a lot like windows in the Finder. Select by Size in Anarchie's 
View menu or click Size at the top of the Anarchie listing window to arrange the files in order
of decreasing size.

You can also view files in order of Date, Kind, Machine, Name, Path or Zone.
Did you know that…
…you can quickly delete a file    or folder on an FTP site?

Drag the file or folder to the Finder's Trash can - just like any file on your disk!

Warning: You can not undo this process, so be careful.
Did you know that…
…Anarchie is really clever?

Anarchie has a lot of clever features. Here are some general guides:
        * The Control key is a modifier which means Edit.
        * Listing windows behave like Finder windows.
        * The Option key is a modifier which means 'Do it slightly differently'.    Try Option-double
clicking an entry in a listing window.
Did you know that…
…you can upload multiple files and folders?

Drag and drop the files or folders from the desktop into a listing window. It works just like 
copying files in the Finder.
Did you know that…
…you can copy and paste URLs in the FTP FTP… windows?

Copy and paste a URL into one of Anarchie's FTP… windows, and Anarchie fills out the 
correctly the fields out for you.

Hold the Option key down to copy a URL from a FTP… window.
Did you know that…
…Anarchie can tell you when it needs to be updated?

Anarchie supports SIVC (Simple Internet Version Control), which means that Anarchie 
automatically checks, every now and then, if a new version has been released.

Enable SIVC by choosing Preferences in Anarchie's Edit menu and checking Allow SIVC 
Version Checking.
Did you know that…
…you can email Tech Support for help from the About box?

Open the About box from the Apple menu and click the email address.    Or check out the 
Frequently Asked Questions on Anarchie at:

      <http://www.stairways.com/stairways/anarchie/>



(Command-click the above URL to open it.)
Did you know that…
…you can force the transfer mode?

Normally Anarchie automatically works out what mode it should use to transfer files.    You 
can temporarily change what mode Anarchie will use to upload and download files by 
selecting the mode from the bottom of the FTP menu.

When you next startup Anarchie it will default to Automatic.
Did you know that…
…you can upload into subdirectories of a listing window?

When dragging files into listing windows you can drop them on to directory items in the listing window to 
put the file into that directory.
Did you know that…
…you can store bookmarks to your favourite FTP sites?

Select Save Bookmark… from the File menu, or hold the control key down and drag your 
selection to the Finder to create a Bookmark. 
Did you know that…
…you can make Netscape Navigator use Anarchie for its FTP transfers?

Download Netscape FTP Switcher from your local UMich or Info-Mac mirror. It's a script that 
tells Netscape to use Anarchie for FTP URLs.

To find Netscape FTP Switcher: select Mac Search from the File menu and search for 
'ftpswitcher'.
Did you know that…
…you can pay for your shareware online?

You can register through your Web browser at:

      <http://kagi.direct.net/cgi-bin/register1.cgi?PL>

(Command-click the above URL to open it.)

Or, open Anarchie's About box and click 'Please Register Your Copy.' to open the Register 
application.
Did you know that…
…you can eat a bicycle?

Michel Lotito also known as Monsieur Mangetout, has eaten (amongst other things) 10 
bicycles, seven TV sets and a Cessna aircraft.
Did you know that…
…you can automatically view text files on FTP sites?

Select the file in the listing window, go to the FTP menu, and chose View Selection.
Did you know that…
…you can rearrange Anarchie's windows?

Select Send To Back from the Window menu to send the frontmost window behind all the 
others.



Did you know that…
…you can examine the history of your FTP transfers?

Select Show Log from the Window menu. You can repeat commands in your log by double 
clicking an entry in the log listing.
Did you know that…
…you can modify how Anarchie copies URLs?

When you copy a URL from a Listing Window, the Log Window or anywhere else in Anarchie 
it is automatically formatted to 72 columns and angle brackets are put around the text.    
Hold the option key down while you copy out the URL and Anarchie will not add the angle 
brackets or format the text for 72 columns.
Did you know that…
…you can see what is really happening during an FTP transfer?

Select Show Transcript from the Window menu.

This window is helpful for working out what is going wrong when a transfer fails. You can 
Command-click URLs in the transcript window to retrieve files or open links.
Did you know that…
…you can put multiple bookmarks in one file?

Choose List Bookmarks from the File menu. Select multiple items using the Shift or 
Command keys, and then choose Save Bookmark… from the File menu.
Did you know that…
…you can do pattern matching in the Get via FTP window?

You can put patterns in the Path and Anarchie will only display files whose path and filename
match that pattern.    For instance, if you put:

*j*

…only files with a j in them will be displayed in the resulting file listing.
Did you know that…
…you don't need to fill in a username when you are doing anonymous FTP?

Anarchie will automatically fill in the username as anonymous and use the E-Mail address 
you have configured in Internet Config.    You only need to fill in the username and password 
when you are not using anonymous FTP.
Did you know that…
…you can make bookmarks with a username in them?

Connect using your username and password and choose Save Bookmark… from the File 
menu. The Username is then stored in the bookmark.

The password is not stored in the bookmark.
Did you know that…
…you can add a password to a bookmark?

Connect to a site using the correct username and password, then save a bookmark at that 
site. Open the bookmark in a text editor like BBEdit and enter the password between the : 
and the @ characters. Save the bookmark.



Warning: Your password is now visible in plain text to anyone who opens that file! Be careful 
who has access to that bookmark!
Words from the Oracle…

Drawing on my fine command of language, I said nothing.
Did you know that…
…you can automatically FTP to the Stairways FTP site?

Open the About box and click the word Anarchie. Or just Command-click on this URL:

      <ftp://ftp.stairways.com//stairways/>
Did you know that…
…you can automatically find out when a new version is released?

Anarchie automatically tells you when a new version has been released if you enable SIVC. 
Enable SIVC by selecting Preferences from the Edit menu and checking the Allow SIVC 
Version Checking checkbox.
Did you know that…
…you can automate Anarchie using AppleScript?

Anarchie is both scriptable and recordable. Example scripts come with the Anarchie 
distribution. The example scripts are also available on Anarchie's Web pages.
Did you know that…
…Anarchie can FTP through firewalls?

Set your firewall preferences by selecting Firewalls… in the Edit menu, which opens Internet 
Config's Firewalls panel. You can now enter your firewall preferences. Note: This requires 
Internet Config 1.3.

If you do not have Internet Config 1.3 Command-click the URL below:

        <ftp://ftp.stairways.com//stairways/>
Did you know that…
…you can move files around on an FTP site?

Select the file you wish to move in a listing window, choose Rename… from the FTP menu, 
and enter the full path to the file and the (new) name for the file.
Did you know that…
…you can upload into folders in a listing window?

Drag the files or folders you are uploading over a folder in the listing window to upload to 
that particular folder.      The folder will highlight to indicate your upload destination.
Did you know that…
…you can find out the transfer speed in bytes per hour?

During a download click the Bytes/Sec field and it cycles through:
            Bytes/Sec
            Bytes/Min
            Bytes/Hour
Did you know that…
…you can retrieve the latest list of Archie servers?

Select Update Server Lists from the Edit menu to make Anarchie get the latest list of Archie 



servers.
Words from the Oracle…

Applying computer technology is simply finding the right wrench to pound in the correct 
screw.

A big thanks to Ambrosia Software for hosting the Mac Search server. Ambrosia produce a 
range of high quality software. They are best known for their excellent game titles such as 
Maelstrom, Escape Velocity, Barrack, and Bubble Trouble. Check them out at:

      <http://www.ambrosiaSW.com/>
Did you know that…
…you can find out when your download is going to finish?

During a download click the Time Left field and it cycles through:
            Time Left
            Time
            Start
            Finish


